Problemer med oppgradering?

Hjelp og support relatert til programmet BAS21.
Svar
Brukeravatar
chreide
Site Admin
Innlegg: 195
Registrert: 06.05.2018 16:10
Sted: Trondheim

Problemer med oppgradering?

Legg inn av chreide » 06.01.2019 13:52

Det har vært meldt noen problemer for enkelte ved oppgradering til 1.2.0, og dette beklager vi. Det har vært mange årsaker til dette, men i hovedsak er årsakene at folk oppgraderer fra veldig forskjellige versjoner. Jo flere versjoner man hopper over jo større sjanse for problemer ved oppgradering (selv om vi gjør vårt beste for å håndtere dette).

Gjennom helga har vi fortløpende laget noen nye installasjonspakker etter hvert som det har dukket opp forskjellige scenarioer. Disse er lagt ut på den vanlige nedlastingssiden. Hvis du har hatt problemer med å installere 1.2.0 vil nok disse løse problemene.

Hvis du fremdeles opplever problemer kan disse diskuteres i denne tråden. Alt lar seg løse!

Oppfordringen er uansett at alle oppdaterer når de får melding om ny versjon! Oppdateringene inneholder feilrettelser du absolutt vil ha!
goverweg
Innlegg: 3
Registrert: 02.01.2019 17:10

Re: Problemer med oppgradering?

Legg inn av goverweg » 07.03.2019 10:50

Forsøkte å oppgradere til 1.2.3 på Mac. el Capitan
Får ikke startet programmet.
Forsøkte å installere 1.2.0 igjen men den sies var ødelagt.
Brukeravatar
chreide
Site Admin
Innlegg: 195
Registrert: 06.05.2018 16:10
Sted: Trondheim

Re: Problemer med oppgradering?

Legg inn av chreide » 12.03.2019 16:12

Kan du sjekke om du har en error-log i katalogen Library/Logs/BAS21/ ?
Innholdet der vil kunne være til hjelp for å finne ut av problemet.
goverweg
Innlegg: 3
Registrert: 02.01.2019 17:10

Re: Problemer med oppgradering?

Legg inn av goverweg » 20.03.2019 11:58

Nei den ser jeg ikke. Det er flere bibliotek mapper og deri Logs mappen men ingen bas 21.

Kommer ikke videre på el Capitan. Har renset med Onyx på all mulige plan installert 1.2.7 nå flere ganger, men nei den åpner og forsvinner :roll:
micawe
Innlegg: 4
Registrert: 21.08.2019 10:23

Re: Problemer med oppgradering?

Legg inn av micawe » 31.10.2019 14:11

Får feilmelding på Fakturering og forhåndsvisning av faktura etter oppdatering.

https://www.dropbox.com/s/d7y9s3xvbej8a ... 6.png?dl=0
Brukeravatar
chreide
Site Admin
Innlegg: 195
Registrert: 06.05.2018 16:10
Sted: Trondheim

Re: Problemer med oppgradering?

Legg inn av chreide » 31.10.2019 15:11

Hmm.. Funker det hvis du setter dato (ihvertfall ca. dato) for registrering i mva-registeret i selskapsinnstillignene?
Brukeravatar
kskjon
Innlegg: 1
Registrert: 06.11.2019 11:53

Re: Problemer med oppgradering?

Legg inn av kskjon » 06.11.2019 11:59

Hei

Prøver å oppgradere fra 1.2.8 til 1.3.1, men får denne meldingen:

Det oppstod feil ved oppgradering av dabasen.
Feilen er logget.

(pymysql.err.ProgrammingError) (1064, "You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'WHERE NOT EXISTS (SELECT * FROM mva_sats WHERE mva_kode = 13 AND sats = 12)' at line 1")
[SQL: INSERT INTO mva_sats (mva_kode, sats, fra_dato) SELECT 13, 12, '2018-01-01' WHERE NOT EXISTS (SELECT * FROM mva_sats WHERE mva_kode = 13 AND sats = 12);]
(Background on this error at: http://sqlalche.me/e/f405)


Har prøvd å rulle tilbake til en backup av databasen og avinstallere/installere BAS21 på nytt, men får alltid samme meldingen.
Brukeravatar
chreide
Site Admin
Innlegg: 195
Registrert: 06.05.2018 16:10
Sted: Trondheim

Re: Problemer med oppgradering?

Legg inn av chreide » 10.11.2019 20:33

Dette gjaldt MySQL spesifikt ja. Fikset i siste versjon.
Svar